Dodge SRT4 Forums - SRT4mation banner
1 - 10 of 10 Posts

· Registered
Joined
·
139 Posts
Discussion Starter · #1 ·
driving home from work (long island) tried to stay off back roads because everything is flooded. I stayed on the double yellow lines figuring my chances were better. every other route home was flooded. I drove through a puddle that was probably 4-6" deep and went very slow. got through fine. car ran fine until I got to light.:doh: When light changed, my car puffed, choked, shaked, and stalled. :rant: I started again, it ran enough for me to pull to side of road. white smoke of death i noticed.

i remember reading a thread about this a long time ago. something like turbo-lock? something of that nature. can someone help me as to what I should do? my uncle told me to pull the plugs and turn it over a few times to see if water shoots out, if so, the cylinders are soaked. What about the turbo?

PLEASE HELP!!!!

Thank God the car is front of my friends house. I was able to get it in front.

much appreciated if someone can acknowledge.
 

· Registered
Joined
·
139 Posts
Discussion Starter · #2 ·
Bump?? come on man
 

· Registered
Joined
·
139 Posts
Discussion Starter · #4 ·
NYYDYNASTY said:
hydro-lock

IF thats what you have...DO NOT turn your car on.

I'll leave the tech answers/suggestions to the experts. thats my only suggestion, at this point.
i just read on the other forum an exact situation. they're telling this dude to pull his plugs and the cold side IC pipe and crank her over until she spits up water. My uncle told me to do the very same. I'm gonna try it tomorrow.

Anyone else? Need help dudes. Fucking rain killed long island and my car.
 

· Registered
Joined
·
1,701 Posts
This rain fucked up a lot of things. Both my cars have CAI's so I havent even left my house all week. I know 3 other people that have hydro-locked their motors and all of them had to get new cars. Good luck man. I hope it works out for you. I think the rain is actually supposed to be stopped now. Might just get a sprinkle tomorow. My girlfriends drivers side windshield wiper just stopped working today on her lunch break so she had to leave the car at work and get a ride home. Rain sucks, I'm movin to Cali.
 

· Registered
Joined
·
139 Posts
Discussion Starter · #6 ·
okay. I was able to get the water out of my car.

The first thing I did was pull the oil stick to see if it was milky. looked good thank God! Then I pulled cold side pipe off and watched the water fall out. and boy did it come uh falln'! Then, I pulled the plugs and turned the car over a few times to push whatever water was in the cylinders out and NOTHING came out. Although 2 of the plugs were a tad bit wet. not soaked.

I removed the JMB cold side pipe from the throttle body and intercooler and put a wet/dry vac on the intake and sucked any wetness out. I also put wet/dry vac on intercooler and repeated. Water kept coming. Pissed I was!

I put new plugs in, reinstalled the wires left the cold side off and started the car. The car smoked for like 2seconds (white smoke) then cleared right up and ran normal! :party: When I got out the car to hit the throttle on the TB, the water came out pretty damn hard. I put the wet/dry vac on while it pumped and yet still it kept coming. I just said fuck it. I took apart the front end and took out my AGP race FMIC. As I pulled it out, about 1.5 gallons of water came out. I couldn't fucking believe it! I literally went through a 6" puddle w/ my aem cai and it sucked like a $2 whore! I never thought it would draw so much.

Anyway.. put everything back together after drying it out. Car runs BUT... WHEN BOOSTING AROUND 6PSI I GET A WHOOOOO SOUND. It's hard to explain but it will not boost over 10psi. The sound comes on strong too. Does anyone know what that is???:dead_hors

I can sure use some input boys. Please advise.
 

· Registered
Joined
·
1,529 Posts
get an 89 civic dx :vtec: :vtec: :vtec: :vtec: :vtec:


its probably your IC pipe. jmb pipes don't like big fmics'...they don't line up right.. you probably have to grind them down like i had to do to mine
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top