Dodge SRT4 Forums - SRT4mation banner

1 - 20 of 41 Posts

·
Registered
Joined
·
650 Posts
Discussion Starter · #1 ·
Allllright....
The car is finally done, and it starts.
now the car has not been tuned yet (cam gears or safc-2) so im not sure if its a tuning issue or could it possibly be something they did during the install of the cams and so on.
As of last night when the car is on the turbo makes a constant fluttering sound (sounds like PTB) but just at idle, once you give a little gas its fine.
Also there is air being pushed OUT of the inlet of the turbo.:confused:
What can cause this? A vac line not re-connected, install of the cams, gears need to be tuned, or is that because of the cams themselves?
All i know we drove it there and it def did not do that.
if i can get my video editing program installed ill upload a clip
thanx again.. and sorry for all these damn questions but this is our first time doing something this big to any of our cars and we dont know 100% what is right and wrong.
 

·
Registered
Joined
·
20,570 Posts
Basically are you asking if you driving whether it be on WOT or hitting the gas you hear the turbo making a flutter sound? If so that's compressor surge your hearing and no, it's not good.
 

·
Registered
Joined
·
650 Posts
Discussion Starter · #3 ·
Basically are you asking if you driving whether it be on WOT or hitting the gas you hear the turbo making a flutter sound? If so that's compressor surge your hearing and no, it's not good.

no it only does it at idle.... i know its not a good thing.... i just dont understand how that starts to happen out of the blue.

it was not doing that when we droped it off.

is it even possible they did something wrong when they installed the cams to do that?
 

·
Registered
Joined
·
20,570 Posts
wow... i'm trying to grasp what this shop did for you. That's a weird situation. I'll call up Jay & see what he thinks.
 

·
Registered
Joined
·
650 Posts
Discussion Starter · #7 ·
im working on getting the vid up
 

·
Registered
Joined
·
650 Posts
Discussion Starter · #9 ·
i would say pull the intake off and see if you have an extreme amount of shaft play, also see if you have any bent fins.

we did that beforehand... there is a lil.... up and down only like 1 mm (none in& out)...

as far as fins... dunno... we will check that
 

·
Registered
Joined
·
650 Posts
Discussion Starter · #11 · (Edited)
beforehand as in before the noise started or after. if it was before i would check it now
we checked it like 2 seconds before we started the car....

im trying to get vegas working so i can put a vid up... damn thing wont work grrr.
then we are off to dyno it....
 

·
Registered
Joined
·
650 Posts
Discussion Starter · #12 ·
well... i cant get a vid.... ill work on something later.... ok we are going to the shop now....

be back on later
 

·
Registered
Joined
·
2,042 Posts
we checked it like 2 seconds before we started the car....
im trying to get vegas working so i can put a vid up... damn thing wont work grrr.
then we are off to dyno it....
well... i cant get a vid.... ill work on something later.... ok we are going to the shop now....
be back on later
this right here is sig material, not to flame but come on car is making weird noise from turbo, not sure what it is, so lets push the car as hard and we can and hope for the best. not smart:woot:
 

·
Registered
Joined
·
1,199 Posts
just watch hozays car sumtimes ;x
 

·
Registered
Joined
·
650 Posts
Discussion Starter · #17 · (Edited)
this right here is sig material, not to flame but come on car is making weird noise from turbo, not sure what it is, so lets push the car as hard and we can and hope for the best. not smart:woot:

no no no.... when i said going to the shop or "dyno" i ment to go and check out the car and try figure out what is going on..... not actully run it. i know i should of not siad it that way.. did not think before i typed

i still did not get to go yet... busy day.

i was thinking.... before all this work was done, the only time we would get that fluttering sounds was with ptb (agp wga) so is it possible it may have something to do with that or the mopar blue plate?.

wheni get back today thats the first things im going to check.




i just thought of somthing else...

why would strong air be coming out of the inlet of the turbo when in idle, and then when you give a little gas it goes through like norm? it only flutters when air is coming out of the inlet. maybee something is beeing blocked?

i dunno... just came to mind
 

·
Registered
Joined
·
1,701 Posts
Dunno what your problem is, but you should definitely be getting rid of that blue plate with your setup...........
 

·
Registered
Joined
·
650 Posts
Discussion Starter · #20 ·
Dunno what your problem is, but you should definitely be getting rid of that blue plate with your setup...........
yea we just ordered a BFMIC and hard pipes are NEXT... like in 1-2 weeks... and i have the hks bov already
 
1 - 20 of 41 Posts
Top